React Native初探

  • 时间:
  • 浏览:2
  • 来源:UU快3—全天最准大发快三

安装命令:

因此打开四个 多 项目目录,打开cmd命令行输入以下命令创建工程:

2.加快react native启动的几种方法:

(六)Unable to resolve module 'AccessibilityInfo'

执行npm view yarn version 查看yarn版本号,当前的版本号为1.7.0

执行 yarn -v 查看安装的yarn版本号,我当前的版本为1.7.0

执行yarn --version 查看安装的yarn版本号,我当前的版本为1.7.0

打开目录/android/app/src/main/java/com/项目名/MainActivity.java,找到getMainComponentName()方法,我这里返回的是rn_demo1,事实上我项目根路径名字叫做rn_demo。我只须要改成rn_demo就好了。

下载好随后,克隆好友node的安装路径,在path中加上node环境变量。

在cmd中输入 npm -v 回车,如下图:

可不须要使用脚本打开,

(1)安装方法有以下四种 :

安装完成后在cmd中输入 npm -v 回车,如下图:

(二)编译并运行 React Native 应用

示类似下:

运行成功如下图所示:

【建议】

(四)机会模拟器上运行项目冒出"Unable to load script from assets 'index.android.bundle'.Make sure your bundle is packaged correctly or you are running a package server."没办法 的错误为什么会么会会么会避免?

错误如图所示:

(一)使用命令行创建新项目

JDK下载地址:http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

图示如下,我当前的react-native-cli版本号为2.0.1:

打开Android Studio,File --> Settings --> 搜索sdk,找到对应的sdk进行安装即可,这里也可不须要选用安装模拟器,找到对应的勾选进行下载即可。

须要在Path环境变量中加上四个 多 值。分别是 Android SDK中tools目录的路径和platform-tools的路径。(机会机会配置,就不让再去配置了。)

类似:

输入python命令即可。

(七)Invariant Violation:Applicaction 你的项目名称 has not been registered.This is either due to a require() error during initialization or failure to call AppRegistry.registerCommponent.

官网地址:

2、使用npm工具下载yarn:

配置环境变量:

根路径底下的index.js文件打开,请看AppRegistry.registerComponent('rn_demo', () => App); 我这里括号内参数1为rn_demo,和项目根路径名称是一致的。

(二)手动打开安卓模拟器

(五)机会第四步的什么的现象还没办法 避免,建议使用以下方法创建和安装应用:(你这一 又是四种 构建方法,和rn有点硬区别,可不须要玩一下,但不建议学你这一 。)

yarn官网 https://yarnpkg.com/zh-Hans/

机会官网打不开,可不须要查看中文网:

yarn中文网 https://yarn.bootcss.com/

我这里选用的版本是1.7.0,你也可不须要选用统统版本,下载好了随后,双击安装,因此把yarn安装路径配置path环境变量中。

JDK须要配置四个 多 环境变量:(机会已配置就不让再配置)

查看node版本号:

react native版本什么的现象,建议下载react-native 0.55.4版本,以及react-native-cli 1.2.0 版本,具体操作如下:

打开cmd命令行,逐个输入以下命令:

加上环境变量:

Android Studio

避免方法:

1.进入\android\app\src\main目录,新建assets文件夹。

2.进入项目根目录cmd运行以下命令:

(一)什么的现象1 The development server returned response error code: 10000

双击,指定路径,下一步就可不须要完成安装了。

SDK和安卓模拟器:

通过npm命令安装的,可不须要有以下几种方法选用:

在刚创建的rn项目根目录,打开命令行,输入react-native run-android命令,如图所示:

随后是npm命令:npm install --save react-native@0.56.0

你可不须要使用yarn命令替代:yarn add react-native@0.56.0

(三)什么的现象3 RN默认是用的gradle3.5构建的,统统建议使用AS2.3.X版本(因此只有大于3.0.0版本)导入项目。我用的是AS3.1.3,gradle构建成功的,因此命令行执行react-native run-android命令老是报各种错,问了别人也找只有避免方案,机会是RN对高版本的AS工具以及高版本的gradle不兼容吧。

我这里用的版本是2.7.13,下载地址:https://www.python.org/downloads/release/python-2713/

查看npm版本号:

1、yarn官网下载yarn安装包:

※【说明】npm工具是nodejs底下自带的,统统假如配置了nodejs环境变量就OK了,不须要单独配置npm到环境变量。

(2)相关命令:

Node官网: https://nodejs.org/

机会官网打不开,可不须要看nodejs中文官网 https://nodejs.org/zh-cn/

3、升级yarn版本号:

Android Studio的下载地址请看:https://developer.android.google.cn/studio/#downloads

安装方法:指定安装路径,老是点击下一步就可不须要了。

查看python安装版本:

图示如下:

示类似下:

建议:把项目底下的android目录导入到Android Studio,让Android Studio工具帮你自动构建。

类似:

(二)什么的现象2 关于命令行提示gradle的一次错

你这一 什么的现象一般是配置的什么的现象,避免方法如下,确保registerComponent(参数1)getMainComponentName()返回值你这一个多 保持一致就OK:

react native中文网 https://reactnative.cn/

下载:

1.安装完 yarn 随后就可不须要用 yarn 代替 npm 了,类似用yarn代替npm install命令,用yarn add 某第三方库名代替npm install --save 某第三方库名

使用react-native init 项目名称创建项目,如图所示:

安装:

好多人说rn好用,老是要推荐我用,你可不须要不信了,来安装玩一下试试效果。实践出真知!安装过程各种坑,工具太少了,太麻烦了,差点放弃(还好坚持下来呢)。

避免方法:

在刚创建的项目的根目录运行下列代码:

首先执行yarn remove babel-preset-react-native,因此再执行yarn add babel-preset-react-native@2.1.0

使用命令npm install -g yarn就可不须要安装yarn了。

统统前端工具的安装都依赖于node的包管理器npm

加上环境变量, 示类似下:

安装地址:

安装路径:

通过msi安装的,可不须要卸载旧版本的yarn,因此官网下载新版的yarn,因此安装。

【注意】通过msi安装的yarn并不让覆盖通过npm安装的yarn,两者一并趋于稳定。卸载一句话,也是分开卸载的。